[iOSアプリ開発]CoreData のデータ構造を変えた場合に起こるエラー:The managed object model version used to open the persistent store is incompatible with the one that was used to create the persistent store.

CoreDataを利用しアプリの開発をしているときに次のようなエラーに遭遇しました。


The managed object model version used to open the persistent store is incompatible with the one that was used to create the persistent store.

このエラーが生じる原因としては、
CoreDataのデータベース構造が新しくなったのにもかかわらず、simulatorやiphone実機内のデータベース構造が古いままの状態になっているときに生じます。

そこで、
解決策としては、

一度、simulatorやiphone実機から開発中のアプリケーションを削除してから再度ビルドしてみてください。
きっとうまくいくはずです。